Landmark Systems - Microsoft Office Issues – Incident details
All systems operational
Microsoft Office Issues
Resolved
Operational
Started about 1 month agoLasted 1 day
Affected
Cloud (cloud.landmarksystems.co.uk)
Degraded performance from 4:18 PM to 9:33 AM
Updates
Resolved
Resolved
A fix has been deployed and we are continuing to monitor.
Investigating
Investigating
We are aware of the current Microsoft Office Issues being experienced, and are currently investigating the cause. We apologise for any inconvenience this may have caused and will provide updates as and when they occur.