Landmark Systems - Cloud 1 outage – Incident details

All systems operational

Cloud 1 outage

Resolved
Major outage
Started 7 months agoLasted about 2 hours

Affected

Cloud 1 (cloud1.landmarksystems.co.uk)

Major outage from 1:11 PM to 3:22 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Cloud 1 cannot be accessed at the moment. We are currently investigating the issue and will provide updates as they appear.